SPViewPermissionSetting acting like it's not working at all.

Jan 26, 2010 at 4:44 PM

Moss 2007 installed on Server 2008 32 bit. Took the helpdesk template and modified it to meet my needs. Installed SPViewPermissionSetting as directed and activated. It worked out the box just fine. I was able to set the view permissions and have it work correctly, as in it would take a "viewer" and only show their default view of "my active service requests" and not allow them to even see any other views as a selection. I was just notified that "viewers" can now see all views which show info they should not see.

The only thing that has changed is that we have added a couple new views after I installed and activated SPViewPermissionSetting. After adding the new views, I am able to go to list settings, view permission settings (powered by Bewise) and set permissions on them. But it seems that after I added those views, that now none of the permission settings work.

As of right now if a "viewer" goes to the list, they can see all the views. They DON'T have the default view that is set for them (my active service requests) coming up as the default. And no matter what I change it just flat out doesn't work and assign the correct permissions on views.

I have tried the usual remedies of rebooting. I even removed the wsp completely and re-installed, re-deployed, and re-setup the permissions but it still isn't working. I have read that there is a "reset" button I can't get it to come up to do an actual reset. Does anyone have any idea what I could do to restore these view permissions?

Jun 1, 2010 at 2:39 PM

Doesn't seem to work here either.

Ik use WSS 3.0 on server 2003.